CodeCharge Studio
search Register Login  

Visual Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> Java

 how to set these path

Print topic Send  topic

Author Message
nappa

Posts: 4
Posted: 08/22/2006, 2:05 PM

hi there,
I've been trying to set up the paths of java SDK and java ANT in code charge studio, but I've failed doing it. I set the exact jdk and ANT in it, but still it report errors when I try to publish the project.

Anybody have any idea where I've missed ?
This software is pretty hard to configue, I think. I took me whole night trying to confique things to work right.
View profile  Send private message
jres
Posted: 08/22/2006, 10:10 PM

Hi!

The paths to java and ant must be the same as in the case specifying the ANT_HOME and JAVA_HOME environment variables. For example, if you install jdk to c:\java\jdk1.5 folder you must use "c:\java\jdk1.5" as value for JAVA_HOME variable or for JAVA SDK Home in Tools->Options->Paths dialog. Please note if you specify JAVA_HOME variable you needn't to specify JAVA SDK path in CCS options. The same for ANT: if you install ANT to 'c:\java\ant' folder you must use this to set environment variable ANT_HOME or Java Ant Home. And again if you specify enviroment variable you needn't to set option.
nappa

Posts: 4
Posted: 08/22/2006, 10:23 PM

thanks, the jdk and ANT seem to be working now, but I'm currently have class path problem. May be it because I don't know how to specify the environment variable, as you said. Can you guys teach me how to do it ? If not so, please tell me how I can specify class path in code charge studio.

many many thanks.....
View profile  Send private message
jres
Posted: 08/22/2006, 10:37 PM

You have two ways:
- you can specify CLASSPATH environment variable and add to it servlet-api.jar and jsp-api.jar from, for example, tomcat 5.x distributive (<tomcatHome>\common\lib)
- you can specify CLASSPATH for each project in Menu->Project->Settings->Server/Script->ClassPath property.

For both cases you must specify full path to each jar-file. For example:
c:\java\tomcat-5.5.17\common\lib\servlet-api.jar;c:\java\tomcat-5.5.17\common\lib\jsp-api.jar

I preffer to set enviroment variable because I don't think about classpath when start new project.
nappa

Posts: 4
Posted: 08/23/2006, 9:55 AM

Thanks for your help. I tried that ,but when I put the servlet-api.jar and jsp-api.jar into ccs it report as they are image files. So I can't add them to the system.

After that I tried setting up the environment variable,but nothing seem to be working.:-O

It also reported "servlet 2.2 API is not found in your class path".
View profile  Send private message
jres
Posted: 08/24/2006, 10:26 PM

Hmm....
It is very strange...
I set up System Environments variables ANT_HOME, CLASSPATH and JAVA_HOME and have no any troubles...

May be you set them as 'User variables'?
Please try to define them as 'System variables' and of course restart CCS after doing that.
nappa

Posts: 4
Posted: 08/26/2006, 5:58 PM

I finally get the classpath done. Unfortunately there's seem to be another problem. The project build successfully ,but when I start tomcat it couldn't run the page.

"resource unavailable"

That's what it say. Do you have any comment on that?

Thanks a lot for being here for me. Without you I'm not gonna make it .;-)
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.