CodeCharge Studio
search Register Login  

Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> General/Other

 Japanese Locale and Encoding Error

Print topic Send  topic

Author Message
sakura

Posts: 4
Posted: 06/12/2016, 9:57 PM

Dear all.

I use CCS Series in Japan,And I have some trouble it.

CCS5 Japanese Location & Encode setting has been switched from an old version.
(CCS5)
1.Locale and Encoding -> File Encoding : Unicode(UTF-8)
2.Locale and Encoding -> Dafault HTML Encoding : Unicode(UTF-8)
3.Site Locales:Japanesse(Default) ->Output encoding :Japanese(Shift-JIS)
(old version)
1.Locale and Encoding -> File Encoding : Japanese(Shift-JIS)
2.Locale and Encoding -> Dafault HTML Encoding : Japanese(Shift-JIS)
3.Site Locales:Japanesse(Default) ->Output encoding :Japanese(Shift-JIS)

Trouble1.
ASP's Grid and Recorde Builder(Internationalize option checked) has FAILURE display.
1.After building , The first Japanese indication is right,
but title is diplay illegal character ,when I pushed the Add button.
And bad recording text.(ex [input] ねこ -> [recode]ねぁEButton_Insert=クエリ送信  )
CCS1to4 is no problem(Shift-JIS).

trouble2.
Fileupload additional(ABC Upload &VBScript) is changed 2-byte Filename.
(ex. CCS5注意1.txt -> 20166131250300.ccs5__1.txt )
CCS1to4 is no problem.

trouble3.
CCS5's ALL Locale setting to Japanese(Shift-JIS) like CCS old version,
However, i cnnnot improve it.

I wish go back up to be usable in Shift-JIS likely old version.
View profile  Send private message
solesz

Posts: 137
Posted: 06/14/2016, 11:08 PM

I am not sure that i fully understand the case, but first i would check the database connection and interface if capable to handle utf8.
Second, the content of the database has to be encoded with utf8 or it can cause serious datadisplay problems representing data in utf8 wich was encoded different way.
Third, after a so deep change in the project I usually delete all published files (but the data stored in file structure, i.e. upladed files) and let CCS regenerate it fully making no doubt, that every and all file are already from the new version.
If no other way, then check the http header and raw data coming back from server to analize what data are you receiving.
View profile  Send private message
sakura

Posts: 4
Posted: 06/16/2016, 1:52 AM

I found another BUG.
I set CCS5 to shift-jis in the same way as an old version.

[html TAB]
<meta http-equiv="content-type" content="text/html; charset=shift_jis">
[live page TAB]
<meta http-equiv="content-type" content="text/html; charset=shift_jis_jis_jis">

・one double- quotation mark short. [html TAB]
・shift_jis_jis_jis is bad definition. [html TAB][live page TAB]

hmm....
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

PHP Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.