CodeCharge Studio
search Register Login  

Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> General/Other

 Getting Update Panels to work

Print topic Send  topic

Author Message
AndyGB4

Posts: 122
Posted: 01/13/2016, 7:41 AM

Hi, I've used lots of Update Panels in the past, but recently (i'm using 5.1.1.18990), they just don't seem to be working for me. Has anyone else had trouble with Update Panels lately?

It's a very simple example too. I have a Search & Grid inside an update panel, and I don't want the entire page to refresh when I search. Only the search & Grid should refresh. But instead, it refreshes the whole page. I wonder if I'm doing something wrong, but I've used Update Panels correctly for years now. It's weird that all of a sudden I'd have these problems...

Anyways, let me know if you guys get them to work. Thanks!
View profile  Send private message
AndyGB4

Posts: 122
Posted: 01/13/2016, 9:17 AM

Ok so, I'm not sure what I did differently, but now if I click the Search button, it will indeed do a search, and only the Search & Grid get refreshed. So that's working. But I'm still getting odd results.

The Grid in question is in Gallery view, and there are 5 columns. So for example, with 8 items in the Grid when I load it up (there will be more eventually), it should show like this:

[X][X][X][X][X]
[X][X][X][_][_]

[X] = has data, [_] = empty

And when the grid loads, it DOES show that. But when I do a search (any search), i get very weird results... For example, if it still returns the 8 items, it formats it like this:

[X][X]
[X][X][X][X][X]
[X]

Or sometimes it'll have empty spaces at odd places:

[X][X][_]
[X][X][X][X][_][_]
[X][X]

I can't wrap me head around this issue! I tried creating a new grid, with out all the formatting, and it gives the exact same result as the other grid. I don't get it... :(

View profile  Send private message
MichaelMcDonald

Posts: 638
Posted: 04/04/2016, 6:46 PM

I've been wondering how the whole json encode deliver the php to a specific grid works in ccs.

I got the grids to perform as update panels but lost link functionality - not pushing the url parameter to the header....
_________________
Central Coast, NSW, Australia.

View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Internet Database

Visually create Web enabled database applications in minutes.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.