CodeCharge Studio
search Register Login  

Visual PHP Web Development

Visually Create Internationalized Web Applications, Web Reports, Calendars, and more.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> General/Other

 <!DOCTYPE HTML> Declaration

Print topic Send  topic

Author Message
Cris

Posts: 78
Posted: 01/07/2016, 3:30 AM

Hi guys,

I have an annoying problem with the declaration of HTML 5 <! DOCTYPE html>.

After saved my pages, CCS delete the statement <! DOCTYPE html> from the HTML codes and inserts some ASCII characters that have nothing to do with the HTML code.

What you suggest to do?


Thanks for suggestions

_________________
------
Cristiano
Skype: cris-do

View profile  Send private message
Oper


Posts: 1181
Posted: 01/07/2016, 6:39 AM

That error come from the version of IE you have installed
_________________
____________________________
http://www.7bz.com (Free CMS,CRM Developed in CCS)

http://www.PremiumWebTemplate.com
Affiliation Web Site Templates

Please do backup first
View profile  Send private message
Cris

Posts: 78
Posted: 01/07/2016, 10:27 AM

Quote Oper:
That error come from the version of IE you have installed



Hi Oper and thanks but maybe Im not explain better.. after saving the webpages if I reopen the webpage in the HTML tab the CCS automatically delete this declaration .

_________________
------
Cristiano
Skype: cris-do

View profile  Send private message
Oper


Posts: 1181
Posted: 01/07/2016, 11:31 AM

you are explaining ok, and that behavior is because your IE

Keep in mind CCS use the Engine/Motor of Explorer

PS:and that is not the only behavior
_________________
____________________________
http://www.7bz.com (Free CMS,CRM Developed in CCS)

http://www.PremiumWebTemplate.com
Affiliation Web Site Templates

Please do backup first
View profile  Send private message
Cris

Posts: 78
Posted: 01/07/2016, 12:45 PM

Quote Oper:
you are explain ok, and that behavior is because you IE

Keep in mind CCS use the Engine/Motor of Explorer

PS:and that is not the only behavior


Ok. First I never used IE but onlyFirefox and maybethe old versions of Firefox do not use HTML5 . What can I do to solve this problem?


_________________
------
Cristiano
Skype: cris-do

View profile  Send private message
ReneS

Posts: 225
Posted: 01/07/2016, 1:02 PM

Hi,

What version of internet explorer do you have installed?


It does not matter if you don't use it, CodeCharge uses it...

Rene


View profile  Send private message
rbaldwin

Posts: 156
Posted: 01/10/2016, 5:37 AM

Given that Microsoft has announced that IE 11 is the end of IE and IE is the engine behind CCS, and there may not be development happening with CCS, a future with CCS seem pretty bleak.
View profile  Send private message
MichaelMcDonald

Posts: 638
Posted: 01/10/2016, 10:31 PM

Comment duly noted. Certainly the end-of-life of Internet Explorer will impact CCS profoundly.

The cracks started appearing a revision or 2 ago when certain JS functions were removed from IE due to 'security reasons' and CCS had to be patched.

Maybe one of the standards compliant browser developers will release an IE emulation/VM app for their browser to maintain all the ongoing development that ends up running on their platforms.

Might be time to look at forming a group to port CCS to eclipse ! LOL !

I was looking at a BPM tool called Bonitasoft - if that had php/asp integration it's possibilities are limitless.
_________________
Central Coast, NSW, Australia.

View profile  Send private message
Oper


Posts: 1181
Posted: 01/11/2016, 5:30 AM

CCS4 working without a problem with (Edge Explorer) in Windows 10
_________________
____________________________
http://www.7bz.com (Free CMS,CRM Developed in CCS)

http://www.PremiumWebTemplate.com
Affiliation Web Site Templates

Please do backup first
View profile  Send private message
eratech


Posts: 513
Posted: 01/12/2016, 2:09 AM

From a project some years ago, it was a module in IE that did all the XML parsing, so if something like that is still available then CCS should be OK.

Project was converting Word documents to XML / XSD into HTML.

Not as much fun as it sounds...

Eric

_________________
CCS 3/4/5 ASP Classic, VB.NET, PHP
Melbourne, Victoria, Australia
View profile  Send private message
MichaelMcDonald

Posts: 638
Posted: 01/18/2016, 10:59 PM

Hey Eric,

I'm pretty sure there was some JS function dropped between IE10 and 11, cannot remember which.

Also, not related but could be :) ??? - Some of the CSS3 browsers have dropped support for adding attachments in a "modal" view (not the compact view) when using Outlook Web Access. Apologies for the ambiguity regards the JS involved but certainly happened.

Here's some info..

http://www.msoutlook.info/question/owa-broken-chrome-37

and quote:

As of Chrome 37, the �showModalDialog� API has been deprecated by the Chrome development team and completely removed as of Chrome version 42.
_________________
Central Coast, NSW, Australia.

View profile  Send private message
eratech


Posts: 513
Posted: 01/19/2016, 12:03 AM

MichaelMcDonald - thanks for the link for OWA and chrome. Bit surprised that something like ModalDialog got dropped (sounds like a fairly common thing to have)

That link lead me to silverlight which I honestly thought had stopped development. I'm not interested in installing another plug-in and all the silverlight apps I've seen (and I had to use one last week) all look about 5+ years old and lots of semi-transparent buttons that look like lollies.

Eric
_________________
CCS 3/4/5 ASP Classic, VB.NET, PHP
Melbourne, Victoria, Australia
View profile  Send private message
MichaelMcDonald

Posts: 638
Posted: 01/19/2016, 3:46 AM

http://stackoverflow.com/questions/29935216/window-show...log-replacement

http://www.codeproject.com/Questions/816993/Modal-Popup...rking-in-Chrome

I'm not having any problems with modals showing... so maybe it is something to do with pop-ups inside modals...
_________________
Central Coast, NSW, Australia.

View profile  Send private message
Oper


Posts: 1181
Posted: 01/19/2016, 5:25 AM

Personal choice for Modal Window i'm Using jQuery

that way i dont has to worry about cross-browsing solutions, work even in IE8
_________________
____________________________
http://www.7bz.com (Free CMS,CRM Developed in CCS)

http://www.PremiumWebTemplate.com
Affiliation Web Site Templates

Please do backup first
View profile  Send private message
MichaelMcDonald

Posts: 638
Posted: 01/30/2016, 3:50 AM

I came across it again - object attachEvent was dropped after IE8.


http://stackoverflow.com/questions/20180046/attachevent...-work-in-ie-8-0

Deprecated they call it :-D
_________________
Central Coast, NSW, Australia.

View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

MS Access to Web

Convert MS Access to Web.
Join thousands of Web developers who build Web applications with minimal coding.

CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.