CodeCharge Studio
search Register Login  

Web Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> Perl

 perl application not running right

Print topic Send  topic

Author Message
lyleholc

Posts: 5
Posted: 05/02/2014, 4:02 PM

Hi,

I generated a simple perl project using application builder, templates, perl. The app generated and produced .cgi and .html files for the list and maint pages for my mysql table.

However, if i run open the html file with http, the display is not graphical and not all the functionality is present. So something is haywire with the setup or generation. I've checked the hppd conf file and the perl and cgi lines are enabled.

I'm using the perl instance that I use with dwimperl, padre, strawberry perl and they all work fine.

I don't know what file my browser should execute, but using the list.html and getting the partially functional, non graphical display.

Should there be another file to run other than the .cgi and.html?

Any thoughts/recommendations much appreciated.

Thank you,

Lyle
View profile  Send private message
eratech


Posts: 512
Posted: 05/05/2014, 10:25 PM

Not perl specific, but check your Publishing settings to see if all the correct files have been published - sometimes it might miss out the CSS files or some third party JS depending on the settings.

Also - what do you mean by 'not graphical' - is it some plain text without styles, or something else? Again, this might point to the Styles for the project not being published.

You can also publish individual Folders and files using right-click > Publish in the Project explorer, but check the publishing settings first.

Eric
_________________
CCS 3/4/5 ASP Classic, VB.NET, PHP
Melbourne, Victoria, Australia
View profile  Send private message
lyleholc

Posts: 5
Posted: 05/06/2014, 12:00 AM

Hi Eric,

Thanks for responding.

Couple things.

First, the CodeChare help file relating to Perl shows a number of Properties to set. One is Code File Extension and the value shown is CGI. If I use this, then only .cgi and .html pages are created by the generator. I'm assming to run the application that the generator should create .pl pages.

As per the my comment on non-graphical, what I mean is that if I run the .html page in a browser then the page is rendered text-based.

Thanks again for any thoughts.

Lyle
View profile  Send private message
eratech


Posts: 512
Posted: 05/06/2014, 5:37 PM

Lyle,

I have never set up a perl app, but I've had some similar problems with PHP apps with the HTML template files being loaded in preference to the same-named PHP file that actually does the work.

Assuming the CGI file is the worker and the HTML is just the template, is there a setting on the server of which document to use first? (ie: index.cgi before index.html)

E
_________________
CCS 3/4/5 ASP Classic, VB.NET, PHP
Melbourne, Victoria, Australia
View profile  Send private message
lyleholc

Posts: 5
Posted: 05/06/2014, 8:09 PM

Hi Eric,

Well, nothing I can find. I've looked through the Help and read articles about setting up Apache for Perl, and followed all. But something must be missing in the instructions because, if you follow them including the project properties, no .pl files are generated. I had to change from the recommended settings to get them.

I kind of thought that generating the Perl apps would be as easy as for php, but can't find a full example from someone that actually got Perl to work.

Thanks again,

Lyle
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.