CodeCharge Studio
search Register Login  

Web Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> ASP

 [RESOLVED]Reset search fields after executing search on a grid

Print topic Send  topic

Author Message
Chris__T


Posts: 339
Posted: 09/14/2009, 7:40 AM

I have the basic search record connected to a grid. After entering my search criteria (some textboxes, some listboxes) and pressing "search", I want the search record to reset to default (empty textboxes, "select value" in the listboxes). But I want to make sure it searches and displays grid results before going back to defaults. Any ideas?
View profile  Send private message
jjrjr1


Posts: 942
Posted: 09/14/2009, 8:31 AM

In the Properties pane for the seach component add the search parameter names to the Remove Parameters property.

Or try preserve parameters property to none.

_________________
John Real - More CodeCharge Studio Support at - http://CCSElite.com
View profile  Send private message
Chris__T


Posts: 339
Posted: 09/15/2009, 7:33 AM

That didn't seem to work. When the page refreshes after you press the search button, it shows the search results in the grid, but the search fields in search box still have search criteria in them.

And preserve parameters was already set to none.

Thanks.
View profile  Send private message
jjrjr1


Posts: 942
Posted: 09/15/2009, 5:12 PM

You might need to explicitly remove each search parameter in the Remove Parameters property.
_________________
John Real - More CodeCharge Studio Support at - http://CCSElite.com
View profile  Send private message
jjrjr1


Posts: 942
Posted: 09/15/2009, 9:48 PM

BTW. If using the remove parameter property does not work....

Try nulling the controls out in the before show event


_________________
John Real - More CodeCharge Studio Support at - http://CCSElite.com
View profile  Send private message
Chris__T


Posts: 339
Posted: 10/08/2009, 2:37 PM

Nulling the controls in the before show event worked. Thanks jjrjr1 !
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.